THREAD: HDMI Problems
  1. 01-08-2017, 02:34 PM
    Dylan's Avatar
    Dylan
    Haxor!
    Dylan's Avatar
    Dylan
    Haxor!
    46
    Posts
    14,628
    Reputation
    Feb 2016
    NextGenUpdate
    So my laptop has had this issue for ages. I've dealt with it and listened to it as it is, but now I'm tired of it.
    Whenever I connect my laptop to my tv through hdmi the video will play through but the audio still comes from the laptop and it never pops up in the audio selection to select the tv to play it from. Any suggestions? Much appreciated.
  2. 01-08-2017, 04:57 PM
    Sparrow's Avatar
    Sparrow
    Big Papi
    Sparrow's Avatar
    Sparrow
    Big Papi
    1,098
    Posts
    7,833
    Reputation
    Nov 2016
    NextGenUpdate
    Have you tried a different HDMI cable? Or updating drivers on your GPU? Restarting TV when connected?

    Could also try below if nothing else works:

    • Open Device Manager
    • Click the little triangle on the left next to "sound, video and game controllers" to make it drop down
    • You'll now see your sound devices, I for example have 2, one is "ATI..." the other "Realtek..." (depends on hardware obviously)
    • Right click each one in turn and click "disable". Click "yes" when the warning pops up.
    • When they're both turned off, right click each of them again and click "enable".



    Annoying but gets the job done when nothing else works :/
  3. 01-08-2017, 05:43 PM
    Kam's Avatar
    Kam
    Investor - Future Millionaire
    Kam's Avatar
    Kam
    Investor - Future Millionaire
    6,814
    Posts
    62,200
    Reputation
    May 2015
    NextGenUpdate
    Originally Posted by Dylan View Post
    So my laptop has had this issue for ages. I've dealt with it and listened to it as it is, but now I'm tired of it.
    Whenever I connect my laptop to my tv through hdmi the video will play through but the audio still comes from the laptop and it never pops up in the audio selection to select the tv to play it from. Any suggestions? Much appreciated.


    All HDMI cables should transmit both audio and video at high quality. However, it may be your HDMI cable that is defected. Try getting a new one. Also, perhaps the sound system on your TV isn't configured to play out of the TV. I know on my TV I have the option to make it come from both the TV Speaker or the device connected to it.
  4. 01-09-2017, 08:47 AM
    motoX's Avatar
    motoX
    Bounty hunter
    motoX's Avatar
    motoX
    Bounty hunter
    172
    Posts
    823
    Reputation
    Apr 2010
    NextGenUpdate
    right click speaker icon...select playback devices...find your tv...make default device.
  5. 01-09-2017, 01:34 PM
    Dylan's Avatar
    Dylan
    Haxor!
    Dylan's Avatar
    Dylan
    Haxor!
    46
    Posts
    14,628
    Reputation
    Feb 2016
    NextGenUpdate
    Originally Posted by Kam View Post
    All HDMI cables should transmit both audio and video at high quality. However, it may be your HDMI cable that is defected. Try getting a new one. Also, perhaps the sound system on your TV isn't configured to play out of the TV. I know on my TV I have the option to make it come from both the TV Speaker or the device connected to it.


    I believe I have tried different HDMI cables, i know for sure I've tried multiple TVs no difference though. Will try a different cable when I get one. Thanks
  6. 01-09-2017, 02:04 PM
    Kam's Avatar
    Kam
    Investor - Future Millionaire
    Kam's Avatar
    Kam
    Investor - Future Millionaire
    6,814
    Posts
    62,200
    Reputation
    May 2015
    NextGenUpdate
    Originally Posted by Dylan View Post
    I believe I have tried different HDMI cables, i know for sure I've tried multiple TVs no difference though. Will try a different cable when I get one. Thanks


    If you've tried different TVs and different cables, then it is definitely a setting on the laptop.

    On the laptop, go to the bottom where you see the sound button in the task bar. Right click it and go to Playback Devices. Find the HDMI, it should say Realtek High Definition Audio and set it as the Default Device.
  7. 01-09-2017, 02:19 PM
    Dylan's Avatar
    Dylan
    Haxor!
    Dylan's Avatar
    Dylan
    Haxor!
    46
    Posts
    14,628
    Reputation
    Feb 2016
    NextGenUpdate
    Originally Posted by Kam View Post
    If you've tried different TVs and different cables, then it is definitely a setting on the laptop.

    On the laptop, go to the bottom where you see the sound button in the task bar. Right click it and go to Playback Devices. Find the HDMI, it should say Realtek High Definition Audio and set it as the Default Device.


    All that shows up is the speakers when the hdmi is plugged in


    Edit: going onto the device properties:
    "This device cannot start. (Code 10)

    {Operation Failed}
    The requested operation was unsuccessful"
    Last edited by Dylan ; 01-09-2017 at 02:24 PM.

  8. 01-09-2017, 02:37 PM
    Kam's Avatar
    Kam
    Investor - Future Millionaire
    Kam's Avatar
    Kam
    Investor - Future Millionaire
    6,814
    Posts
    62,200
    Reputation
    May 2015
    NextGenUpdate
    Originally Posted by Dylan View Post
    All that shows up is the speakers when the hdmi is plugged in


    Edit: going onto the device properties:
    "This device cannot start. (Code 10)

    {Operation Failed}
    The requested operation was unsuccessful"


    What type of HDMI Cable is it? Is there a company listed on it?
  9. 01-09-2017, 03:29 PM
    Dylan's Avatar
    Dylan
    Haxor!
    Dylan's Avatar
    Dylan
    Haxor!
    46
    Posts
    14,628
    Reputation
    Feb 2016
    NextGenUpdate
    Originally Posted by Kam View Post
    What type of HDMI Cable is it? Is there a company listed on it?


    Nah doesnt say, AWM Style 20276 80 C 30V conductive shield high speed hdmi all it says on it
  10. 01-09-2017, 06:44 PM
    Kam's Avatar
    Kam
    Investor - Future Millionaire
    Kam's Avatar
    Kam
    Investor - Future Millionaire
    6,814
    Posts
    62,200
    Reputation
    May 2015
    NextGenUpdate
    Originally Posted by Dylan View Post
    Nah doesnt say, AWM Style 20276 80 C 30V conductive shield high speed hdmi all it says on it


    I would definitely try another cable then.